[Google Photos] Linking Images Within Forum Posts

Gadgetron_3000

RED SHIRT
Hi, Everyone!

Sites like Imgur and Flickr make it relatively easy to link images to forum / article posts, but Google seems to discourage that kind of sharing. A lot of times when one is logged into his / her Google account and viewing an image in Photos, it seems easy enough to just right-click over the image, select "Copy image address" or "Copy Image Link," and use that somewhat super-long URL in a post. However, once the person logs off of Google, that URL link no longer becomes valid which then creates a problem within the post.

There is a convoluted workaround, however. So here is a how-to write up on linking images from your Google Photos account to posts on this forum.

1. Through your web browser, log into your Google Photos account.

2. Click on the image you wish to view.

3. On the upper-right section of the display, click on the "Share" icon.

AM-JKLVflViLB0USbNdEDieWjxctGQ8O7PgdcrM64Fp6FnAncy5koMjolJwz7-r-ylLnaxcRR1bZguWxLG4wG0gqF6C761mwCnvSy2A_lhtGrt54_S199sbbVZN1sMkLTRQNHk3uHoTGaSme6K6PYya5UpwTJg=w720


4. A "Send in Google Photos" window appears. Click on "Create link."

AM-JKLVbuk-bOB8Qep6Gac_hFEHy1XTUKzxSIfLC_BBGo1QjRAtymnoyCUJZePLLX3FCEU6biKqgED9eHNmtRLQ2-dF9Lt_P0buVal8Ya2MC7_olI2CWOn9m3ZZieqsBb6Y1zKlHYWrHRvzkdtTs-yWY5tU_RQ=w720


5. A "Create link to share" window appears. Click on the "Create link" button.

AM-JKLXXW26q0BB-zxs-Khz9bxZt9VkBLWZQrF7ieBJgTjBRzeD6c5zLswt188ueQOduNwuGtlZ66fSOjUEjgETFWymVd-GxnKjXgE-x_rfhiBhDCaKLPVa8Ke2Z1uUiffncVwqeaau9dbnK4b6C2ksmO2FGqw=w720


6. A short URL link appears. Copy it.

AM-JKLV92S2BoJkWcI7cRoIKnt-YYSqFejBojCsmCBv8N8Gx0STvqZIn7d4NWJbLFWKbYmu4MkyyWXo0QbqwjhAo3wwZNeqRXhvRLs9PNvum93s143XGpmXo5ukCLGkqsMufvz6dMuhf6QAE4xz5uBCprw-tGA=w720


7. Open a browser tab or other brand web browser that ISN'T logged into ANY Google account. Paste the URL and go to the Google Photos link.

AM-JKLVsL8pQaFcQOsqWw1BSs9pRrvzky2uuffYAL1wXB2twPPaJmP1BCH-E88dtroHKtQqsg-5xnOwyoKTKcyAo8P1aqzbJS9ohYMr5ApX5_zDV_PF6r5lpzb8z1ZSA0obF_A-z9pW5_5WvySfFMUTqI3-vfQ=w720


8. Single-click on the image. It should expand to better fill the display.

AM-JKLUSr4Q8HkPXTmK39CgPaSHbbQGfYkk-VnAYwPJddsfP68PPQOOAkH2YjcQ2QSn0Bk-uSFtmfmi5DjZeZX1tlyH7ynwiyUtF2X_FnywQ_t-90gCSY3zh5jNovTlIseJFIddPV-aVq49JxTF7yPSmr2oAIg=w720


9. Right-click over the image and select "Copy image address" or "Copy Image Link."

AM-JKLWk0s-rcTzAVg7r1_7M0VhEOnfXOyvju7iouKapIKOxhiE63kNRbxxO59xfBzOKR2M0NDrnCUcwF9xOe-cs5kXzNKC4KBwNA-dCOp9sqDoEAP7aY0PjnVdQ3kt2Awihatrh0iJV7S99o5xRPq2WGxlvtw=w720


10. Open a text editor and paste the copied link. Notice that at the end of the link there is an equal ("=") symbol followed by a w-value and a h-value. Those numbers represent the pixel width and height of the image as it appears in the browser tab display.

AM-JKLXVI7CwoCbXqdT2FFUvNgZUUhLAh510ofZC-UxNCDc3BUI3XexWrRMVbJmt-n3Phgu77Nlln65RS8_VAVNNYqTIAozn45MHvLJRVjeVn8ez7swuGN108S34EmUqNtTxgnJKZh5SNqF9Vb38ZKiplhqHXQ=w720


11. Change everything after the equal symbol to "w720". This will force the linked image to display at a width of 720 pixels. I find that this value works best for forum posting use. Copy that updated URL link.

AM-JKLU7c8EJCGL9cAjeR4WWyDpoZXdmjIcm9JYvZYUyQjWPKxoFwLZ83e7mEhNwCa569nHwfaanR8oVtGC5X7j62b8aR52KrEve9jhznQO5tuU9VHn8HexK91gfcFThdipx5uANgkbZnFPG9hUQHwLSv78yxQ=w720


12. Go back to the HLI Community forum and begin the Post thread process. Type something out. When you want to place the linked image, click the "Insert image" icon on the formatting ribbon.

AM-JKLXP3rb2Fau4AR8rBpejljyDuOYPkC6P6Oi6mJCh6S2UfuY1fK2myxv3fF6OW46qPfYIHEhYCl26XHiI5OkBvWtHHtf30TTrPSp3UWGTKrlwh2fNf5tJ_EB9ZMLQ16HIJmszydWM672KbWYLCQdniaZhFQ=w720


13. Click the "By URL" icon and paste in the previously copied URL. Click the "Insert" button.

AM-JKLVW5XTq20gyOL2h5efeDZjY_wXdbaFBiMvDUO5nFs2ytIXG4WgyT6zDgg6R0HSHRD08siqNdCClskm29SP7GBRL8oi04MDKjS8QWu3eeKlg0rc78cNwNW3QshziA1WZNr308_R3TeIRiNNcqWMEc14BDg=w720


AM-JKLViIQ7L6vuz_EGhMMGgRSq3eCyR_9nGs8NUjvGqN4kHOrjB1HS2CsUTiKfxqk168QJULodMTzIW8TNWmgc8HajTyhd8J8n2n6PaESeY03DjihjFHdnVx-aq78uKAHf06zqfX_4Cyvaiz5kHYGzr46uMFQ=w720


14. If you did everything correctly, the image should appear.

AM-JKLVrnBcDTkimufvlE2PHCQ20nZm8pE-FNQAeLeLULGOkOvlPy-qJ4t4iIoCnEvrwn4lF3DZ5rkmeAvqAIjtnPJVzP3wmQdNccsWecimsmloexeuZysfbB-BSRp0geqFDZ1Le-Yj7Vvliu-9wVtqd2pDwiA=w720


I use this method all the time. Yes, it's more time consuming, but it works perfectly. And like linking images from sites such as Imgur and Flickr, it saves the forum site from having to store and host a copy of the pictures one wants to use in a post. Adjust the workflow to better suit how you might need to.

I hope this is helpful.

:)
 
Top